ShipRite Update 10.17.2
Time to Download: 25-40 Seconds.
Time to apply update: 4-15 minutes depending
on database size. It is recommended you download this at the end of day, and not as you
arrive for work, unless you get to the center at least 1 hour ahead of time.
To LOAD the UPDATE
1. Backup your ShipRite database. You should be backing up DAILY. If you are not, please
go to www.shipritesoftware.com/FAQS and download, then apply the backup
procedure.
2. The update has to be done on the server computer with ShipRite closed on all other
workstations.
3. On the Server, from the main ShipRite screen click on the EOD button. In the top right
corner click on the Program Updates button.

4. A ShipRite Updates status screen will display with information that the update is being
downloaded. Depending on internet speed, this can take a few minutes to complete.
When done, a message will display informing that the Update Downloaded
Successfully. Close the Screen and close out ShipRite completely.

5. After closing ShipRite, open it right back up from the desktop shortcut. During the
initial startup, a message will appear informing that the Program Update has been
located. Click YES to install the update.
Follow any prompts on the screen to complete the update installation including the
installation of the ShipRiteNet 3.5 module. Close when done.
6. After the installation is completed, start ShipRite back up from your normal icon. The
first time ShipRite is started up, the software will go through a lengthy loading
procedure. This is normal.
You may get a RUN TIME error that says database update failure. Click OK and ignore it, then
restart the program. The second restart will clear the error message. You should then get a
message saying DATABASE UPDATED WITH XX NEW DATA FIELDS. There is no correct number
on how many fields are added to the database.

The update is now completed. Please scroll down to the What’s New section for
description of changes and new features.
In case that the Program Update button fails to download the update
It’s possible that a firewall or anti-virus software blocks the Program update from being
downloaded. If that is the case follow these instructions:
1. Backup your ShipRite database. You should be backing up DAILY. If you are not, please
go to www.shipritesoftware.com/FAQS and download, then apply the backup
procedure.
2. Click <<HERE>> to download the update.
3. SAVE to your desktop. Double click on the file name: Update_10.17.2.exe
4. Click NEXT to start the loading process, then FINISH to finish the installation.
5. Next you will receive a message that the ShipRite Dot Net 3.5 needs to update. Go
ahead and click YES and continue until done. Click CLOSE when done.
6. Start the ShipRite Program from the normal icon. You will get a message that X
number of Database fields were added. This is normal. You will be required to
restart the program again.

Once the ShipRite Main Menu screen pops up, you are updated.

What’s New:
1.
Emailing of AR Statements
This update includes the capability to automatically email account statements to AR
customers.
In order for this function to work, email capability has to be setup in ShipRite. If email is
already setup and the existing email features (such as emailing POS receipts, tracking
numbers, and/or package and mail receiving notifications, etc.) are already being used,
then no setup needs to be done.
Otherwise, go to Setup > General Setup Options > Global Features > FORM - Email
Setup, and enter in your email server configuration and log in credentials.
Emailing statements is processed in the exact same way as printing statements. The AR
screen can be accessed from the main ShipRite screen by going to Actions > Accounts
Receivables. There, click the “Please Pay” button to open the Statement Processing
screen and process statements for all accounts that have a balance.
Alternatively, a specific account can be pulled up first, then click on the “Please Pay”
button to process a statement just for that account.
The process of emailing the statements works exactly the same as when printing
statements. Make the selection of Statement begin, end, statement, and due dates;
select the format report option with the amount of details needed on the statement,
then press the Email button. All generated statements will get emailed to AR accounts
that have an email address saved in the Statements tab of the AR screen in the Billing
Email field.
If some accounts are missing email addresses, go to Actions > Accounts Receivables,
lookup the account and select the Statements tab on the left. Find the account’s billing
email there and add/verify the email address. Press Save on top to save changes.

2. Emailing of Mailbox notices
Mailbox renewal, expiration, and cancellation notices can now be emailed directly to
the customer either individually or in bulk.
From the main ShipRite screen go to Actions > Mailbox Manager. The last option is the
“Bulk Email Notices” function. After selecting it, 3 buttons will display giving the option
to email either the renewal, expiration, or cancellation notices in bulk.
To email an individual notice, select a specific mailbox on the right-hand side, then click
the Print button on the top. Below the Reprint notice functions, the Email Notice
options are now present. These will email the selected notice to just that box holder.

In order for these email functions to work, an email
address has to be associated with the main mailbox
holder. If there is no email address present, then go to
POS > Customer Lookup. Find the mailbox holder
there, add their email address, and click Save.
To setup the time periods for which boxes to generate
the notices for, go to Actions > Table Management >

Mailbox Setup. In that screen edit the 3 fields for the days to print Renewal, Expiration,
and Cancellation. Then enter in the number of days when to print the notices.
For example, entering -14 in the “Days to Print Renewal” means that at the earliest the
renewal notice will generate 14 days before the box expires.
If entering 25 for the “Days to Print Cancellation”, then at the earliest the cancellation
notice will generate 25 days after the box expires.

The email option will also appear in the Tickler
that displays at the start of the day:

3. Scheduled Invoices for AR Accounts.
ShipRite can now automatically generate repetitive invoices every month and
automatically apply credit card payments to those invoices.
This feature functions by selecting a completed invoice and setting up the repetitive
invoicing for the exact same invoice. This invoice will repeat each month at a set date
over a certain period of time.
To enable the Repetitive Invoicing, go to Setup > General Setup Options > Options >
“ENABLE – Repetitive Invoicing”. Turn that option ON, then click Save and Exit.

Please continue under section A or section B depending if you need to automatically
apply a credit card payment to the repetitive invoice.
A. Set up repetitive invoice and charge it to an AR account
B. Setup repetitive invoice and automatically run a stored credit card to apply payment
to it.
A.

Setting Up Repetitive Invoices without automatic payment.

To setup this function, go to the POS, click on Customer Lookup and pull up the
customer (the customer has to have an AR account). Now create the invoice by ringing
in the needed SKU’s. Click Receipt to open the payment screen and click the “Complete
Sale” button to charge the invoice to the account (do not take any payment at this
time).
Once the sale is completed, click on the Invoice Lookup button and double click on the
just created invoice to view it in the POS. On the top menu, an option for “Repetitive
Invoice” will appear.

Once that option is clicked a message will display informing you that a repetitive
invoice is being setup. Click “YES” to proceed.
The next message will prompt to enter the date to start automatically generating the
selected invoice.
On the selected date, an exact copy of the
currently selected invoice will get created. Click
OK to proceed.

In the following message box enter in the number
of months to repeat the invoice. Enter in -1 to
keep repeating the invoice indefinitely.

The final pop up message will confirm that the repetitive invoicing has been set up.
Click OK. The Invoice will remain displayed in the POS. Do not close it out yet, check the
instructions below to apply payment.

B. Setting up repetitive invoices with automatic credit card payment
The automatic credit card payment only works if using a Cayan Genius terminal to
process a credit card.
In POS click on Invoice Lookup and pull up a sale that the repetitive invoice has to be
setup for. The sale has to been paid for by credit card.
Alternatively, create a new invoice in POS by ringing up the needed SKU’s. Click the
Receipt button to open the payment screen. Click on Credit Card and process the
payment through the Genius terminal. At this point a receipt will print out and a token
will be created with the credit card information encrypted and stored on the Cayan
server. Once the sale is completed and paid for, click on the Invoice Lookup button and
double click on the just paid invoice to view it in the POS.
Once the completed invoice is pulled up in POS, on the top menu, an option for
“Repetitive Invoice” will appear.

Once that option is clicked a message will display informing you that a repetitive
invoice is being setup. Click “YES” to proceed.
The next message will prompt to enter the date to start automatically generating the
selected invoice.
On the selected date, an exact copy of the
currently selected invoice will get created. Click
OK to proceed.

In the following message box enter in the number
of months to repeat the invoice. Enter in -1 to
keep repeating the invoice indefinitely.

The final pop up message will confirm that the repetitive invoicing has been set up.
Click OK. The Invoice will remain displayed in the POS.
For the upcoming repetitive invoices, ShipRite will use that token to automatically
process a payment for the created invoice.
In case that any other form of payment is taken, or no payment is taken at all, no
automatic payments will be applied to the repetitive invoices. They will simply be
charged to the account each month and added to the running balance.
Stopping repetitive invoices
If you wish to get a list of all your repetitive invoices, then please go into the POS
without selecting a customer account > Hit “Actions” at the top > Select “Repetitive
Invoices” at the top. This should then display all original repeating invoices for your
customers.
In order to cancel and stop specific repetitive invoices from being created, pull up the
customer tied to the invoice in the POS. Then please click “Actions” at the top >
“Repetitive Invoices” and find the invoice number you wish to stop. Please note that
invoice number then exit that screen and go to “Invoice Lookup” on the bottom. Pull
up that noted invoice number, then on the top menu click on “Repetitive Invoice”. A
message will appear to confirm the deletion of the repetitive invoice schedule. Click
YES. The scheduled repetitive invoice will then be cancelled.

4. AR Alpha List Report
A new Accounts Receivable alpha listing report is now included. The report will list all
accounts that are currently setup in your software. The difference between this report
and the AR Aging summary is that it will include all accounts, including ones that do not
have a balance.
To print that report from the main menu go to Actions > Accounts Receivable > File >
Print > AR Alpha Listing.

5. 9/3/2017 USPS Rate Update
This update also includes the new USPS First Class Parcel pricing that will take effect on
9/3/2017. Installing the update will download the new rates, however they will not be
applied until 9/3/2017.
On September 3rd, when opening ShipRite, a message will appear that the rates have
been loaded.

The only rates that changed are domestic First Class Mail parcel retail
rates. All other USPS pricing remains unaffected.
To verify that the new rates took effect, on September 3rd 2017 go to
Actions > Table Management > Master Shipping Table > USPS > FirstClass
> Costs & Retail. Scroll to the right and check the “COST-Pack” column.
The pricing should match this table:

Also, remember to check the “RETAIL-Pack” column and adjust your retail
pricing.

Fixes Included in version 17.2
Type Module

Description

Fix

AR

AR Aging report should show data based on the AsOfDate selected.

Fix

AR

AR account balance and aging summary needs to apply available credits to the aging debits so
aging values are accurate.

Fix

Inhouse

PostNet: Download coupons.up_ via HTTP instead of FTP.

Fix

POS

Standard POS: Allow user to delete hold/quote invoice lines.

Fix

POS

Deleting line from hold/quote invoice with discount will cause total to not evaluate correctly.

Fix

Coupons

Coupon Start and End Date should be inclusive in the effective date range.

Fix

Reports

Run z-report code if 'CONSOLIDATED' is passed to loadmenu().

Fix

USPS

Regular Priority Mail cost will show Cubic Rate cost if applicable.

Fix

USPS

Czech Republic is included in USPS Express/Priority Mail Intl Exceptional Size Limits.

Fix

QBO

Need to get most current default browser and check if the exe exists when getting default
browser.

Fix

QBO

Coupons allocation rounding can cause QBO journal entry to be off balance by a small amount.

Fix

QBO

Coupons allocation needs to compare department names case insensitive.

Fix

Reports

MBX key deposits should be included in production report by dept.

New USPS

SR Cubic Rate Feature option added to USPS Carrier Setup.

Fix

Inhouse

When moving contact history to new account, AcctName should be updated.

Fix

USPS

Insurance Names list was empty in MST - USPS Insurance.

Fix

POS

ShipTo address on the receipt will only show the first address line.

Fix

Inhouse

Change instances of 'note', 'Note' to 'NOTE'.

Fix

Inhouse

Delete PostNet CC tables if found in non-postnet shiprite db.

Fix

ShipMaster

Ship Address in Shipping Master will only show first address line when using auto-complete.

Fix

AR

AR Ledger listing no longer showing old Ledger Notes.

Fix

Inhouse

PostNet: One time update added to make sure IsServer local field is set based on the
shiprite.ini setup to correct PNLink Down POS message.

Fix

POS

If older invoice, payment uses original date as default. Should use current date for payment.

New POS

Repetitive Invoicing added to POS and startup.

Fix

POS

PostNet: Remove PNLink Down message from workstation computers.

Fix

MailBox

Don't advance MBX renewal date by 1 day.

Fix

USM

USM specific .upd import doesn't process names with MBXNamesList table used in MBX
package processing.

Fix

USM

USM specific .upd import will erroneously add mailbox with no info for contact not found in
database.

Fix

DHL

Can't delete DHL package from Shipment History.

New Net.EndiciaWeb

DYMO stamp request was added.

New Net.Gateway2ShipRiteNet DYMO stamp request was added.
New VB62Net

DYMO stamp request was added.

New MailMaster

If DYMO Account is enabled then Endicia Web Service will print stamps.

New ProgramSetup

DYMO account won't have 'Change Pickup Location' option.

New ProgramSetup

DYMO Stamps Activation Code option to enter the code was added.

Fix

DHLWeb

Commodity element should have a valid commodity code, or the Commodity element needs to
be removed all together.

Fix

SpeeDee

If 3rd party insurance is turned on, then $0.00 should be reported. If 3rd party insurance is
turned off, then the insured value should be displayed.

Fix

UPS

Pricing Matrix: Don't set price to 0 if UPS Letter weight over 0.5 lbs.

New MergeMaster

Update MergeMaster look and functionality.

Fix

MergeMaster

When merging contacts/accounts, update name values in tables where applicable.

Fix

ShipMain

Disable Dock Hand Manager & Purchase Orders menu items from main shiprite form.

Fix

Net.MailBox

Check In 'Print Notice' and 'Print Label' labels sometimes are overlapping each other if printed
at the same time.

Fix

Net.MailBox

Clear image buffer before/after printing Check In 'Print Notice' and 'Print Label' labels.

Fix

UPS

UPS Next Day EAM doesn't show for saturday delivery when applicable.

New Net.DropOff

Drop Off Manager UPS drop off web URL updated.

Fix

Net.MailBox

Reload previously saved form settings after updating to new version.

Fix

Net.DropOff

Reload previously saved form settings after updating to new version.

Fix

Reports

Customer Count on Production Rpt should count # of invoices for given period.

Fix

EndiciaWeb

Sending a letter via Endicia gets weight rounded up when submitted to ELS.

Fix

Inhouse

Include relevant info in repetitive invoice records added to db.

Fix

POS

When making repetitive invoice ask for starting date, not a day of the month.

New Inventory.upd

PostNet: US Inventory updates.

New Inventory.upd

PostNet: CA Inventory updates.

Fix

POS

POS Includes Notes not added to POS On-Screen receipt.

Fix

POS

Recalculate receipt total to make sure it's accurate in Standard POS.

Fix

AR

Adding New Contact to Account from AR screen results in editing first contact in list.

Fix

Contact

When clicking Clone Contact, don't create account for contact automatically.

Fix

Contact

When pressing Enter in Name textbox where Name <> "" and (FName = "" OR LName = ""), a
name with a single quote will cause SQL error.

Fix

MailMaster

Shortcut buttons won't print Endicia Web Service DYMO stamp.

Fix

ProgramSetup

DYMO Stamps option to copy Endicia account from Label Server was added.

Fix

ProgramSetup

DYMO Stamps Activation Code option to enter the code was removed.

Fix

ProgramSetup

Added setup option to enable/disable repetitive invoicing.

Fix

EndiciaWeb

Send DYMO stamp image straight to the printer.

New POS

Canada receipts will have HST, PST, GST sales tax break-down.

New Net.ShipRiteReports

Canada receipts will have HST, PST, GST sales tax break-down.

Fix

Inhouse

Process repetitive invoice function at start up updated to process and save repeat CC
transactions.

Fix

Inhouse

Genius repeat sale function updated to correctly process and save repeat CC transactions.

Fix

Inhouse

Updating setup policy doesn't update fields in Setup2 table of shiprite DB.

New Reports

Add SR / PNLink version to Production report.

Fix

Master

FedEx Intl DAS surcharge missing in MST so user can't edit manually added DAS charge when
applied.

Fix

POS

Ability to specify tax jurisdiction at the SKU level rather than just the department level.

Fix

FedEx

Intl Only: Label should show sender as shipper's address. Not store address. Should match
Commercial Invoice.

Fix

UPS

Intl Only: Label should show sender as shipper's address. Not store address. Should match
Commercial Invoice.

Fix

DHL

Intl Only: Label should show sender as shipper's address. Not store address. Should match
Commercial Invoice.

Fix

UPS

PostNet: Separate out "Early Surcharge" from shipping cost before applying discount.

Fix

ContactSearch

When saving/updating contacts in the contact manager, update the last updated date in the
database.

New AR

Add ability to email AR statements in AR Statement Processing form.

New MailBox

Add ability to email Mailbox notices in Tickler, Mailbox Manager forms.

New Inhouse

Added ability to update mailbox rental agreement field in database if
MBContractStatement.upd file is in datapath.

Fix

Mailbox Rental Agreement and contract updated.

Net.ShipRiteReports

New AR

AR 'Print Alpha List' menu option added to AR form to print AR Alpha listing.

Fix

MailBox

Can Origin: When renting mailbox, don't show 1583 form input frame since 1583 form is
inapplicable.

Fix

Net.ShipRiteReports

Can Origin: Don't show termination addendum signature line on Mailbox Rental Agreement.

Fix

Shipping

Can Origin: Only disable "Go Online" button for Purolator, Canada Post.

Fix

EOD

Reenable Program Updates button in EOD screen.

Fix

Inhouse

Remove SQL Update that sets Contacts Country field from 'USA' to 'United States' on every
startup.

Fix

Inhouse

PostNet: Disable USPS Cubic rating.

